summaryrefslogtreecommitdiff
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Powell <petpow@saberuk.com>2019-12-08 19:39:02 +0000
committerPeter Powell <petpow@saberuk.com>2019-12-08 19:59:34 +0000
commita47e2df0ce833e06fa3e4034e64ec084a2bbb2d3 (patch)
tree51b20e031c52f135d927bc23643cbd831a0fddd4 /win/CMakeLists.txt
parent914d8140d98dd0adc54f739dfe550765cc466bac (diff)
Replace our Windows getopt_long wrapper with ya_getopt.
Closes #546.
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index be6617b8b..2df48883f 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -48,6 +48,13 @@ file(GLOB INSPIRCD_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
"${INSPIRCD_BASE}/src/threadengines/threadengine_win32.cpp")
list(SORT INSPIRCD_SOURCES)
+file(GLOB INSPIRCD_VENDORS "${INSPIRCD_BASE}/vendor/**")
+foreach(INSPIRCD_VENDOR ${INSPIRCD_VENDORS})
+ if(IS_DIRECTORY ${INSPIRCD_VENDOR})
+ include_directories(${INSPIRCD_VENDOR})
+ endif()
+endforeach()
+
include_directories("${INSPIRCD_BASE}/win" "${INSPIRCD_BASE}/include")
include_directories(${EXTRA_INCLUDES})