summaryrefslogtreecommitdiff
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
authorAttila Molnar <attilamolnar@hush.com>2015-06-15 22:07:05 +0200
committerAttila Molnar <attilamolnar@hush.com>2015-06-15 22:07:05 +0200
commit77b5bd0dbc10defcbc6bbc49df9da12d6a61dd8c (patch)
treeed70dc46728cd688888aefffdd43b8a58309228c /win/CMakeLists.txt
parentbaccf1eba4f3f49fea0a6eee58474c599e0cf477 (diff)
parent8ffce4d2f3ab29677b466238ce900a85b6c9d693 (diff)
Merge pull request #1058 from SaberUK/insp20+nationalchars
[2.0] Fix various issues with the nationalchars module.
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index 087bd7970..10653cf74 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -74,6 +74,10 @@ install(FILES ${EXTRA_DLLS} DESTINATION .)
file(GLOB_RECURSE EXAMPLE_CONFIGS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${INSPIRCD_BASE}/docs/conf/*.example")
install(FILES ${EXAMPLE_CONFIGS} DESTINATION conf)
+# Install nationalchars files
+file(GLOB_RECURSE EXAMPLE_LOCALES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${INSPIRCD_BASE}/locales/*")
+install(FILES ${EXAMPLE_LOCALES} DESTINATION locales)
+
# Create an empty data and logs directory and install them
file(MAKE_DIRECTORY ${DATA_PATH})
install(DIRECTORY ${DATA_PATH} DESTINATION .)