summaryrefslogtreecommitdiff
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index be6617b8b..2df48883f 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -48,6 +48,13 @@ file(GLOB INSPIRCD_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
"${INSPIRCD_BASE}/src/threadengines/threadengine_win32.cpp")
list(SORT INSPIRCD_SOURCES)
+file(GLOB INSPIRCD_VENDORS "${INSPIRCD_BASE}/vendor/**")
+foreach(INSPIRCD_VENDOR ${INSPIRCD_VENDORS})
+ if(IS_DIRECTORY ${INSPIRCD_VENDOR})
+ include_directories(${INSPIRCD_VENDOR})
+ endif()
+endforeach()
+
include_directories("${INSPIRCD_BASE}/win" "${INSPIRCD_BASE}/include")
include_directories(${EXTRA_INCLUDES})